Проблема с многочисленными записями о PDK-патчах Агента администрирования в Kaspersky Security Center
Статья относится к
- Kaspersky Security Center 13 (версия 13.0.0.11247);
- Kaspersky Security Center 12 (версия 12.0.0.7734).
Проблема
База данных и список имен обновлений заполняются однотипной информацией о PDK-патчах для Агента администрирования.
Причины
Kaspersky Security Center вместо единого PDK-патча для Агента администрирования генерирует патчи на каждом устройстве с установленным Агентом администрирования. Эти патчи отличаются только идентификатором.
Подробнее о PDK-патче смотрите ниже.
Решение
- Скачайте архив с утилитой klsql2.
- Извлеките содержимое архива в любую папку на компьютере, где установлен Сервер администрирования.
- Откройте файл src.sql с помощью текстового редактора.
- Скопируйте в этот файл SQL-запрос для:
- Запустите файл start.cmd от имени администратора, используя учетную запись, под который вы устанавливали Сервер администрирования.
Результаты выполнения запроса сохранятся в файле result.xml. Старые записи о PDK-патчах будут удалены из базы данных, а новые больше не будут добавляться.
Что такое PDK-патч
PDK-патчи формируются из библиотек, которые загружаются с антивирусными базами, и применяются для обновления версии библиотеки в Kaspersky Security Center. Например, для библиотеки OpenSSL формируется два PDK-патча: для Агента администрирования и Сервера администрирования.
Чтобы установить PDK-патч для Сервера администрирования, одобрите его запуск в Консоли администрирования:
Для Агента администрирования PDK-патч устанавливается автоматически, в списке он отображается для информирования.