Общие вопросы
 
 

Утилита HxD для сбора данных с зашифрованного вирусом диска

Статья обновлена: 24 декабря 2025 ID: 16221
 
 
 
 

Если вирус зашифровал весь диск на устройстве и вы собираетесь обратиться в техническую поддержку «Лаборатории Касперского» для анализа, соберите первые 10 МБ данных с загрузочного диска на зараженном устройстве с помощью утилиты HxD. Это поможет специалистам технической поддержки быстрее обработать ваш запрос. Чтобы собрать данные:

  1. Скачайте портативную версию утилиты HxD на нужном вам языке с официального сайта.
  2. Извлеките установочный файл утилиты из архива и запустите его на зараженном устройстве.
  3. Следуйте инструкциям мастера установки. Все параметры оставьте выбранными по умолчанию.
  4. Запустите утилиту от имени администратора из файла:
    • HxD64.exe, если на вашем устройстве установлена 64-разрядная ОС (x64).
    • HxD32.exe, если на вашем устройстве установлена 32-разрядная ОС (x86).

    Чтобы определить разрядность вашей ОС, воспользуйтесь инструкцией.

  5. Нажмите Инструменты → Открыть диск.

Переход к выбору диска в утилите HxD.

  1. Выберите нужный физический диск и нажмите ОК.

Выбор диска в утилите HxD.

  1. Установите курсор в начало записи.

Установка курсора в начало записи в утилите HxD.

  1. Нажмите правой кнопкой мыши в произвольном месте окна утилиты, чтобы открыть контекстное меню, и выберите Выделить блок.

Переход к выделению блока в утилите HxD.

  1. Убедитесь, что в поле Смещение начала установлено значение 0.
  2. Переключите активное поле на Длина, установите значение A00000 и нажмите ОК.

Выделение блока в утилите HxD.

  1. Нажмите Правка → Копировать, чтобы скопировать выделенный фрагмент.

Копирование выделенного блока в утилите HxD.

  1. Нажмите Файл → Новый, чтобы создать новый документ.

Создание нового документа в утилите HxD.

  1. Нажмите Правка → Вставить → ОК, чтобы вставить ранее скопированные данные в новый документ.

Вставка ранее скопированного текста в новый документ в утилите HxD.

  1. Нажмите Файл → Сохранить как, чтобы сохранить файл с собранными данными.

Переход к сохранению собранных данных в утилите HxD.

  1. Выберите место для сохранения файла и нажмите Сохранить.

Прикрепите полученный файл к вашему обращению в техническую поддержку «Лаборатории Касперского».

 
 
 
 
 
Вам помогла эта статья?
Что нам нужно улучшить?
Спасибо за ваш отзыв, вы помогаете нам становиться лучше!
Спасибо за ваш отзыв, вы помогаете нам становиться лучше!